Sunday, October 24, 2010

HTTP 404 Not Found Wss SHAREPOINT 2007 2010 errors web.config Central Administration website

When you try to browse a Central Administration website or a SharePoint website, you may receive the following error message:

HTTP 404 Not Found

Or, the following message is logged in the Application log:
Event Type: Error Event
Source: Windows SharePoint Services 3
Event Category: Topology
Event ID: 6800
Description: The database WSS_Content on ComputerName \Microsoft##SSEE is not accessible to missing Windows Internal Database signatures.


This problem may occur when you install a patch manually or through Windows Update. If another service has connected to the Windows Internal Database prior to the upgrade, SharePoint cannot make a connection, and the upgrade fails. This puts the farm into an inconsistent state that must be resolved by a successful upgrade operation.

To resolve this problem, follow these steps to restart the SharePoint services and to complete upgrade:

1 Click Start, click Run, type cmd, and then click OK.


2 Locate the following folder:
%COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\12\BIN

3 At a command prompt, type the following command, and then press ENTER:
psconfig -cmd upgrade -inplace b2b -wait –force


4 If the upgrade does not complete succussfully, type the following commands at

the command prompt, and press ENTER after each command:


net stop MSSQL$MICROSOFT##SSEE


net start MSSQL$MICROSOFT##SSEE


psconfig -cmd upgrade -inplace b2b -wait -force

Wednesday, October 20, 2010

The list cannot be displayed in datasheet view wss, error message Moss "Server Error in '/_vti_bin' Application"

After installing Bussiness portal 3.0 on any virtual server the following errors noted. These errors are comming on systems which installed WSS or any other software which is using this software. The WSS services will cause the following error messages.

When trying to open a wss website the error message will come as

Server Error in '/_vti_bin' Application.

Runtime Error Description: An application error occurred on the server.


When browsing through asmx pages may get the following messages

Server Error in '/_vti_bin' Application.

Configuration Error Description:

An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: There is no 'EnterpriseInitializationModule' module in the application to remove.



When clicking Edit in Datasheet View to display a list in a Windows SharePoint Services site in datasheet view, you receive an error message that is similar to the following error message:

The list cannot be displayed in datasheet view for one or more of the following reasons. A datasheet component compatible with Windows SharePoint Services is not installed or your browser does not support Active X controls or support for ActiveX controls is disabled

These issues occur when the virtual server on which Windows SharePoint Services is extended does not have Business Portal 3.0 installed. When Business Portal 3.0 is installed on a virtual server, the following actions occur:

1. Business Portal 3.0 adds several httpModules elements to the Web.config file in the root of the virtual server.


2. Business Portal 3.0 removes httpModules elements from all Web.config files that are contained in subfolders that are under the root of the virtual server. This removal occurs for all virtual servers on the server.


To resolve this issue, remove the following lines from the Web.config file that is located in the Drive:\Program Files\Common Files\Microsoft Shared\Web server extensions\60\Isapi folder: